Useful Commands
?
Show ? Online help
show interface ? Online help
show interface serial 1 (sho int s1) sho interfaces activity of serial port 1
show interface ethernet 1(sho int e1) sho interfaces activity of ethernet port 1
show configuration (sho conf) show your routers saved configuration
show line sho the information on all your modem lines
show line 1 show the information of modem line 1
show modem show information of your modem
telnet command ...telnet xxx.xxx.xxx.xxx
telnet xxx.xxx.xxx.xxx 2001 telnet into a modem for dialing out, diagnostics or configuring. Port 2001 is modem 1, Port 2 is
modem2, xxx.xxx.xxx.xxx is the primary ethernet address of your router
CTL SHF 6......x Cisco escape sequence, use this to escape from a telnet to a modem or a lost trace command
clear line 1 reset modem line 1, USE THIS IMEDIATELY AFTER EXITTING A TELNET TO A MODEM
ping command ...ping xxx.xxx.xxx.xxx
trace www.more.net or trace 150.199.x.y command ...trace xxx.xxx.xxx.xxx
who command who is logged on
login login as other user, test your login passwords
write memory save your running configuration to memory
write terminal (wri t) or show running-configuration(sho run) show your running configuration or write it to the terminalu
end quit configuration mode and return to exec mode. CTL Z works too!
Exit back up a level in the configuration mode
terminal monitor (term mon) watch logging and debug commands from the router
debug ? Online help with the debug command
debug modem turn on debugging options for the modem
debug tacacs turn on the debugging options for tacacs authentication
undebug all TURN OFF ALL DEBUGGING! This is need when finished to reduce network congestion
no ........(version of a command to remove) use this to remove a statement from your configuration
copy flash tftp Upgrade your IOS (routers software), must have a local TFTP server or Boot ROM grater then 10.2(8a)
copy running-config tftp copy your routers configuration to your TFTP server
reload remotely restart your route
modem busyout busy a modem out remotely
no modem busyout return a modem to production
Snapshot of a Configuration Session for a 25xx Access Server
Example of Configuring from Scratch
MySchool#)#! Start by configuring the access server lines
MySchool#)#config t
MySchool(config)#line 1 16
MySchool(config-line)#! speed for your modem (mt1432ba here)
MySchool(config-line)#speed 57600
MySchool(config-line)#! set up the line so we can use reverse telnet
MySchool(config-line)#modem inout
MySchool(config-line)#! set up flowcontrol between NAS and modem
MySchool(config-line)#flowcontrol hardware
MySchool(config-line)#! end the line configuration
MySchool(config-line)#end
MySchool#! Now do a reverse telnet to set up the modem itself
MySchool#telnet 198.209.250.15 2001
Trying 198.209.250.15, 2001 ... Open
at
OK
at&fs0=1&c1&d3&e1&e4&e15$ba0$sb57600&w1
OK
CTL SHT 6
x
MySchool#clear line 1
confirm (y) y
[Connection to 198.209.250.15 closed by foreign host]
MySchool#! Now set up the int async interace for IP
MySchool#conf term
Enter configuration commands, one per line. End with CNTL/Z.
MySchool(config)#! Enter interface configuration mode
MySchool(config)#int async group-async1
MySchool(config-if)#! save some ip addresses using ip unnumbered
MySchool(config-if)#ip unnumbered e0
MySchool(config-if)#! header compression is controlled by client pc
MySchool(config-if)#ip tcp-header header-compression passive
MySchool(config-if)#! assign the default ip address
MySchool(config-if)#async default ip address pool ModemsIP
MySchool(config-if)#! allow the user to request the ip address from a pool
MySchool(config-if)#async mode interactive
MySchool(config-if)#group-range 1 16
MySchool(config-if)#! all done
MySchool(config-if)#exit
MySchool(config)#ip local pool ModemsIP 204.184.26.1 204.184.26.16
MySchool(config)#! Setup your ip group addresses
MySchool(config)#end
MySchool#!Now we go back and set up the lines for dialin only
MySchool#!Here we also add in some other suggested line commands
MySchool#conf term
Enter configuration commands, one per line. End with CNTL/Z.
MySchool(config)#line 1 16
MySchool(config-line)#session-timeout 15 output
MySchool(config-line)#modem ri-is-cd
MySchool(config-line)#absolute-timeout 120
MySchool(config-line)#session-limit 1
MySchool(config-line)#terminal-type vt100
MySchool(config-line)#transport preferred telnet
MySchool(config-line)#transport output telnet rlogin
MySchool(config-line)#escape-character NONE
MySchool(config-line)#stopbits 1
MySchool(config-line)#rxspeed 57600
MySchool(config-line)#txspeed 57600
MySchool(config-line)#flowcontrol hardware
MySchool(config-line)#telnet transparent
MySchool#! DONT FORGET TO SAVE THE CONFIGURATION
MySchool#writ mem
Building configuration...
[OK]
MySchool#
Configure a Message-of-the-day Banner for your users to see when they login
MySchool#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
MySchool(config)#banner motd #
Enter TEXT message. End with the character '#'.
*************************************************************
* *
* Welcome to the MOREnetÂAPG staff modem pool. *
* *
* Enter your userid and password as prompted. *
* *
*************************************************************
#
MySchool(config)#end
MySchool#write mem
Configure Your Users and Passwords on the Access Server
MySchool#config t
MySchool(config)#username fflinston password pebbles
MySchool(config)#username brubble password bambam
MySchool(config)#end
MySchool#write mem
Building configuration...
[OK]
MySchool#
Sample Configurations
(These examples use the C-class address 204.184.26.0)
Normal configuration (group IP addresses) using local authentication
hostname MySchool
enable password ernie
!
username charley password charley
username phil password phil
!
interface Ethernet0
ip address 204.184.26.254 255.255.255.0
!
interface Serial0
description Serial Link to MOREnet
bandwidth 384
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
description Frame Relay Link to MOREnet
ip address 150.199.124.2 255.255.255.224
bandwidth 384
frame-relay interface-dlci 200
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address pool ModemIPs
group-range 1 16
!
ip local pool ModemIPs 204.184.26.151 204.184.26.166
!
router rip
network 150.199.0.0
network 204.184.26.0
default-metric 1
distance 255
distance 20 150.199.124.1 0.0.0.0
!
ip http server
ip domain-name gw.more.net
ip name-server 150.199.1.11
ip name-server 128.206.2.252
ip name-server 131.151.254.243
ip route 0.0.0.0 0.0.0.0 150.199.124.1
ip route 10.0.0.0 255.0.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
ip route 127.0.0.0 255.0.0.0 Null0
logging console informational
logging 150.199.1.11
access-list 1 permit 150.199.1.11
access-list 1 permit 198.209.250.25
snmp-server community monitor RO
snmp-server community atwind RW 1
snmp-server trap-authentication
snmp-server location MySchool, MO
snmp-server contact Ben Colley (ben@more.net)
snmp-server host 150.199.1.11 monitor
snmp-server host 198.209.250.25 monitor
!
banner motd ^
**********************************************
* Welcome to the MySchool's modem pool. *
* This service is for registered users only. *
**********************************************
^
alias exec admin enable
!
line con 0
exec-timeout 0 0
line 1 16
session-timeout 15 output
absolute-timeout 120
login local
modem ri-is-cd
terminal-type vt100
transport preferred telnet
transport input all
transport output telnet rlogin
escape-character NONE
telnet transparent
stopbits 1
rxspeed 57600
txspeed 57600
flowcontrol hardware
line aux 0
exec-timeout 0 0
line vty 0 4
exec-timeout 0 0
password bert
login
line vty 4
exec-timeout 3 0
!
Normal Configuration Using Tacacs Authentication
hostname MySchool
enable password ernie
!
username charley password charley
username phil password phil
!
interface Ethernet0
ip address 204.184.26.254 255.255.255.0
!
interface Serial0
description Serial Link to MOREnet
bandwidth 384
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
description Frame Relay Link to MOREnet
ip address 150.199.124.2 255.255.255.224
bandwidth 384
frame-relay interface-dlci 200
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address pool ModemIPs
group-range 1 16
!
ip local pool ModemIPs 204.184.26.151 204.184.26.166
!
router rip
network 150.199.0.0
network 204.184.26.0
default-metric 1
distance 255
distance 20 150.199.124.1 0.0.0.0
!
ip http server
no logging console
access-list 1 permit 150.199.1.11
access-list 1 permit 198.209.250.25
tacacs-server host 198.209.253.1
tacacs-server host 128.206.1.214
tacacs-server extended
tacacs-server notify connections
tacacs-server notify enable
tacacs-server notify logout
tacacs-server notify slip
async-bootp subnet-mask 255.255.255.0
async-bootp gateway 204.184.26.254
async-bootp dns-server 150.199.1.11
!
snmp-server community public RO
snmp-server community monitor RO
snmp-server community atwind RW 1
snmp-server trap-authentication
snmp-server location Columbia, MO
snmp-server contact Ben Colley (ben@more.net)
snmp-server host 150.199.1.11 monitor
banner motd ^
**********************************************
* Welcome to the MySchool's modem pool. *
* This service is for registered users only. *
**********************************************
^
line con 0
exec-timeout 0 0
line 1 16
exec-timeout 0 0
script dialer cisco-default
login tacacs
modem InOut
modem autoconfigure type microcom_hpms
terminal-type vt100
transport preferred telnet
transport input all
transport output telnet rlogin
escape-character NONE
telnet transparent
stopbits 1
rxspeed 115200
txspeed 115200
flowcontrol hardware
line aux 0
exec-timeout 0 0
line vty 0 4
exec-timeout 0 0
password bert
login
line vty 4
exec-timeout 3 0
!
ARA (Apple Remote Access) (Apple Talk access your network)
hostname MySchool
enable password ernie
!
username charley password charley
username phil password phil
!
appletalk routing
arap network 16 ARA Dialins
!
interface Ethernet0
ip address 204.184.26.254 255.255.255.0
appletalk cable-range 1000-1099 1043.152
appletalk zone Admin
!
interface Serial0
description Serial Link to MOREnet
bandwidth 384
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
description Frame Relay Link to MOREnet
ip address 150.199.124.2 255.255.255.224
bandwidth 384
frame-relay interface-dlci 200
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address pool ModemIPs
async dynamic routing
group-range 1 16
!
ip local pool ModemIPs 204.184.26.151 204.184.26.166
router rip
network 150.199.0.0
network 204.184.26.0
default-metric 1
distance 255
distance 20 150.199.124.1 0.0.0.0
ip http server
ip domain-name gw.more.net
ip name-server 150.199.1.11
ip name-server 128.206.2.252
ip name-server 131.151.254.243
ip route 0.0.0.0 0.0.0.0 150.199.124.1
ip route 10.0.0.0 255.0.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
ip route 127.0.0.0 255.0.0.0 Null0
logging console informational
logging 150.199.1.11
access-list 1 permit 150.199.1.11
access-list 1 permit 198.209.250.25
snmp-server community monitor RO
snmp-server community atwind RW 1
snmp-server trap-authentication
snmp-server location MySchool, MO
snmp-server contact Ben Colley (ben@more.net)
snmp-server host 150.199.1.11 monitor
snmp-server host 198.209.250.25 monitor
!
banner motd ^
**********************************************
* Welcome to the MySchool's modem pool. *
* This service is for registered users only. *
**********************************************
^
alias exec admin enable
!
line con 0
exec-timeout 0 0
line 1 16
session-timeout 15 output
absolute-timeout 120
login local
modem ri-is-cd
autoselect arap
autoselect during-login
arap enable
terminal-type vt100
transport preferred telnet
transport input all
transport output telnet rlogin
escape-character NONE
telnet transparent
stopbits 1
rxspeed 57600
txspeed 57600
flowcontrol hardware
line aux 0
exec-timeout 0 0
line vty 0 4
exec-timeout 0 0
password bert
login
line vty 4
exec-timeout 3 0
!
Sub-net Configuration
hostname MySchool
enable password ernie
!
username charley password charley
username phil password phil
!
interface Ethernet0
ip address 204.184.26.126 255.255.255.224 secondary
ip address 204.184.26.158 255.255.255.224
ip address 204.184.26.190 255.255.255.224 secondary
!
interface Serial0
description Serial Link to MOREnet
bandwidth 384
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
description Frame Relay Link to MOREnet
ip address 150.199.124.2 255.255.255.224
bandwidth 384
frame-relay interface-dlci 200
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address pool ModemIPs
group-range 1 16
!
ip local pool ModemIPs 204.184.26.142 204.184.26.157
!
router rip
network 150.199.0.0
network 204.184.26.0
default-metric 1
distance 255
distance 20 150.199.124.1 0.0.0.0
distance 40 204.184.26.125 0.0.0.0
!
ip http server
ip domain-name gw.more.net
ip name-server 150.199.1.11
ip name-server 128.206.2.252
ip name-server 131.151.254.243
ip route 0.0.0.0 0.0.0.0 150.199.124.1
ip route 10.0.0.0 255.0.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
ip route 127.0.0.0 255.0.0.0 Null0
logging console informational
logging 150.199.1.11
access-list 1 permit 150.199.1.11
access-list 1 permit 198.209.250.25
snmp-server community monitor RO
snmp-server community atwind RW 1
snmp-server trap-authentication
snmp-server location MySchool, MO
snmp-server contact Ben Colley (ben@more.net)
snmp-server host 150.199.1.11 monitor
snmp-server host 198.209.250.25 monitor
!
banner motd ^
**********************************************
* Welcome to the MySchool's modem pool. *
* This service is for registered users only. *
**********************************************
^
alias exec admin enable
!
line con 0
exec-timeout 0 0
line 1 16
session-timeout 15 output
absolute-timeout 120
login local
modem ri-is-cd
terminal-type vt100
transport preferred telnet
transport input all
transport output telnet rlogin
escape-character NONE
telnet transparent
stopbits 1
rxspeed 57600
txspeed 57600
flowcontrol hardware
line aux 0
exec-timeout 0 0
line vty 0 4
exec-timeout 0 0
password bert
login
line vty 4
exec-timeout 3 0
!
Configuration of the Aux (Auxiliary) Port
hostname MySchool
enable password ernie
!
username charley password charley
username phil password phil
!
interface Ethernet0
ip address 204.184.26.254 255.255.255.0
!
interface Serial0
description Serial Link to MOREnet
bandwidth 384
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
description Frame Relay Link to MOREnet
ip address 150.199.124.2 255.255.255.224
bandwidth 384
frame-relay interface-dlci 200
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address pool ModemIPs
group-range 1 16
!
interface Async17
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.150
!
ip local pool ModemIPs 204.184.26.151204.184.26.166
!
router rip
network 150.199.0.0
network 204.184.26.0
default-metric 1
distance 255
distance 20 150.199.124.1 0.0.0.0
ip domain-name gw.more.net
ip name-server 150.199.1.11
ip name-server 128.206.2.252
ip name-server 131.151.254.243
ip route 0.0.0.0 0.0.0.0 150.199.124.1
ip route 10.0.0.0 255.0.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
ip route 127.0.0.0 255.0.0.0 Null0
logging console informational
logging 150.199.1.11
access-list 1 permit 150.199.1.11
access-list 1 permit 198.209.250.25
snmp-server community monitor RO
snmp-server community atwind RW 1
snmp-server trap-authentication
snmp-server location MySchool, MO
snmp-server contact Ben Colley (ben@more.net)
snmp-server host 150.199.1.11 monitor
snmp-server host 198.209.250.25 monitor
banner motd ^
**********************************************
* Welcome to the MySchool's modem pool. *
**********************************************
^
alias exec admin enable
!
line con 0
exec-timeout 0 0
line 1 16
session-timeout 15 output
absolute-timeout 120
login local
modem ri-is-cd
terminal-type vt100
transport preferred telnet
transport input all
transport output telnet rlogin
escape-character NONE
telnet transparent
stopbits 1
rxspeed 57600
txspeed 57600
flowcontrol hardware
line aux 0
exec-timeout 0 0
login local
modem InOut
terminal-type vt100
transport preferred telnet
transport input all
transport output telnet rlogin
escape-character NONE
telnet transparent
stopbits 1
rxspeed 57600
txspeed 57600
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
password bert
login
!
Configuration Using Static IP Addresses (each modem has it own IP address)
hostname MySchool
!
enable password ernie
!
username charley password charley
username phil password phil
!
interface Ethernet0
ip address 204.184.26.254 255.255.255.0
!
interface Serial0
description Serial Link to MOREnet
bandwidth 384
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
description Frame Relay Link to MOREnet
ip address 150.199.124.2 255.255.255.224
bandwidth 384
frame-relay interface-dlci 200
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.151
!
interface Async2
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.152
!
interface Async3
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.153
!
interface Async4
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.154
!
interface Async5
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.155
!
interface Async6
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.156
!
interface Async7
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.157
!
interface Async8
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.158
!
interface Async9
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.159
!
interface Async10
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.160
!
interface Async11
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.161
!
interface Async12
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.162
!
interface Async13
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.163
!
interface Async14
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.164
!
interface Async15
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.165
!
interface Async16
ip unnumbered Ethernet0
ip tcp header-compression passive
async mode interactive
peer default ip address 204.184.26.166
!
router rip
network 150.199.0.0
network 204.184.26.0
default-metric 1
distance 255
distance 20 150.199.124.1 0.0.0.0
!
ip http server
ip domain-name gw.more.net
ip name-server 150.199.1.11
ip name-server 128.206.2.252
ip name-server 131.151.254.243
ip route 0.0.0.0 0.0.0.0 150.199.124.1
ip route 10.0.0.0 255.0.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
ip route 127.0.0.0 255.0.0.0 Null0
logging console informational
logging 150.199.1.11
access-list 1 permit 150.199.1.11
access-list 1 permit 198.209.250.25
snmp-server community monitor RO
snmp-server community atwind RW 1
snmp-server trap-authentication
snmp-server location MySchool, MO
snmp-server contact Ben Colley (ben@more.net)
snmp-server host 150.199.1.11 monitor
snmp-server host 198.209.250.25 monitor
!
banner motd ^
**********************************************
* Welcome to the MySchool's modem pool. *
* This service is for registered users only. *
**********************************************
^
alias exec admin enable
!
line con 0
exec-timeout 0 0
line 1 16
session-timeout 15 output
absolute-timeout 120
login local
modem ri-is-cd
terminal-type vt100
transport preferred telnet
transport input all
transport output telnet rlogin
escape-character NONE
telnet transparent
stopbits 1
rxspeed 57600
txspeed 57600
flowcontrol hardware
line aux 0
exec-timeout 0 0
line vty 0 4
exec-timeout 0 0
password bert
login
line vty 4
exec-timeout 3 0
!
Modem Command Strings
http://www.more.net/consulting/modem_strings.html
Sample Initialization & Answer Initialization Strings
MultiTech MultiModem II MT1432
InitString=AT&FX4&C1&D3#A0$BA0&E1&E4&E15#L0S7=60
AnswerInit=AT&FX4&C1&D3#A0$BA0&E1&E4&E15#L0S7=60S0=1&W
BPSRate=57600
MultiTech MultiModem II MT2834BA
InitString=AT&F&C1&D3#A0$BA0E1&E1&E15#L0V1X4S7=60
AnswerInit=AT&F&C1&D3#A0$BA0E1&E1&E15#L0V1X4S7=60S0=1&W
BPSRate=57600
US Robotics Sportster 14400
InitString=AT&FX4&A3&B1&D2&H1&I0&K1&M4&R2S7=60
AnswerInit=AT&FX4&A3&B1&D2&H1&I0&K1&M4&R2S7=60S0=1&W
BPSRate=57600
US Robotics Sportster Si 14.4
InitString=AT&FW2&C1&D2&K3&Q5S7=60S36=7S46=138S48=7S
AnswerInit=AT&FW2&C1&D2&K3&Q5S7=60S36=7S46=138S48=7SS0=1&W
BPSRate=57600
US Robotics Sportster 28800
InitString=AT&FX4&A3&B1&D2&H1&I0&K1&M4&R2S7=60
AnswerInit=AT&FX4&A3&B1&D2&H1&I0&K1&M4&R2S7=60S0=1&W
BPSRate=57600
US Robotics Courier V.32bis
InitString=AT&FX4&A3&C1&D2&M4&H1&K1&B1&R2
AnswerInit=AT&FX4&A3&C1&D2&M4&H1&K1&B1&R2S0=1&W
BPSRate=38400
US Robotics Courier HST Dual Standard
InitString=AT&FB0X4&A3&C1&D2&M4&H1&K1&B1&R2
AnswerInit=AT&FB0X4&A3&C1&D2&M4&H1&K1&B1&R2S0=1&W
BPSRate=38400
US Robotics Courier HST Dual Standard V.34 Fax
InitString=AT&FB0X4&A3&C1&D2&M4&H1&K1&B1&R2S7=60
AnswerInit=AT&FB0X4&A3&C1&D2&M4&H1&K1&B1&R2S7=60S0=1&W
BPSRate=57600
US Robotics Courier V.FC/V.34
InitString=AT&FB0X4&A3&C1&D2&M4&H1&K1&B1&R2S7=60
AnswerInit=AT&FB0X4&A3&C1&D2&M4&H1&K1&B1&R2S7=60S0=1&W
BPSRate=57600
US Robotics WorldPort 14400 FAX/Data PCMCIA 2.0
InitString=AT&FX4&A3&B1&C1&D2&H1&K1&M4S7=60
AnswerInit=AT&FX4&A3&B1&C1&D2&H1&K1&M4S7=60S0=1&W
BPSRate=57600
Supra Express 144 Plus
InitString=AT&F2W2&C1&D2&K3&Q5\N3%C3S7=60S95=47
AnswerInit=AT&F2W2&C1&D2&K3&Q5\N3%C3S7=60S95=47S0=1&W
BPSRate=57600
Supra Express 144i Plus
InitString=AT&F2W2&C1&D2&K3&Q5\N3%C3S7=60S95=47
AnswerInit=AT&F2W2&C1&D2&K3&Q5\N3%C3S7=60S95=47S0=1&W
BPSRate=57600
Supra FAXModem V.32bis
InitString=AT&FN1W2&C1&D1&K3&Q5\N3%C1S7=60S36=7S48=7S95=45
AnswerInit=AT&FN1W2&C1&D1&K3&Q5\N3%C1S7=60S36=7S48=7S95=45S0=1&W
BPSRate=57600
Supra FAXModem 144 LC
InitString=AT&FN1W2&C1&D1&K3&Q5\N3%C1S7=60S36=7S48=7S95=45
AnswerInit=AT&FN1W2&C1&D1&K3&Q5\N3%C1S7=60S36=7S48=7S95=45S0=1&W
BPSRate=57600
Supra FAXModem 288
InitString=AT&FW2&C1&D2&K3&Q5\N3%C3S7=60S95=47
AnswerInit=AT&FW2&C1&D2&K3&Q5\N3%C3S7=60S95=47S0=1&W
BPSRate=57600
Supra FAXModem 288i
InitString=AT&FW2&C1&D2&K3&Q5\N3%C3S7=60S95=47
AnswerInit=AT&FW2&C1&D2&K3&Q5\N3%C3S7=60S95=47S0=1&W
BPSRate=57600
Snapshot of Setup for a Simple/Minimum Configuration
Configure Terminal Lines
MySchool>ena
MySchool#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
MySchool(config)#line 1 16
MySchool(config-line)#modem inout
MySchool(config-line)#absolute-timeout 120
MySchool(config-line)#session-limit 1
MySchool(config-line)#exit
Configure Your Modems' IP Addresses
MySchool#config t
Enter configuration commands, one per line. End with CNTL/Z.
MySchool(config)#
MySchool(config)#ip local pool ModemIPs 192.100.100.1 192.100.100.16
MySchool(config)#end
MySchool#
Configure Your Users
MySchool#config t
Enter configuration commands, one per line. End with CNTL/Z.
MySchool(config)#
MySchool(config)#username bert password ernie
MySchool(config)#username big password bird
MySchool(config)#end
MySchool#
Configure Your Banner
MySchool#config t
Enter configuration commands, one per line. End with CNTL/Z.
MySchool(config)#banner motd ^
Enter TEXT message. End with the character '^'.
***********************
Welcome
***********************
^
MySchool(config)#
MySchool(config)#end
Configure Your Modems
MySchool#telnet 192.100.100.254 2001
Trying 192.100.100.254, 2001 ... Open
**************************
Welcome
**************************
at
OK
AT&FX4&A3&B1&D2&H1&I0&K1&M4&R2S7=60S0=1&W {enter your modem's command string}
OK
at&w
OK
{CTL SHT 6 x} cisco's escape sequence
MySchool#clear line 1
[confirm]y [OK]
MySchool# {retun a line feed}
[Resuming connection 1 to 192.100.100.254 ... ]
[Connection to 192.100.100.254 closed by foreign host]
MySchool#
MySchool(config)#
MySchool(config)#line 1 16
MySchool(config-line)#modem ri-is-cd
MySchool(config-line)#end
MySchool#write mem
Building configuration...
[OK]
MySchool#show config
MySchool#